Page 1 of 1

FTP Failure

Posted: Sat Dec 05, 2020 5:35 am
by texomans
Unsure as to the cause, but I am unable to get reports to upload to our FTP server.I am able to connect to the server without issues using WinSCP, but when trying to configure UVK to upload, I get the error "Failure to send reports by FTP! The remote directory does not exist". The funny thing is that UVK does hit the directory as there is a new .zip file created, but it shows 0KB in size. I have tried Passive mode on and off, different user accounts and ensured users testing have permissions to the folder. Even tried using another folder in the root so that no sub-folders would be required.

P.S. I am aware of the typo in the directory. That was just for the screenshot, but I get the same error when the typo is not present.

UVK-FTP.png (85.74 KiB) Viewed 2996 times

Re: FTP Failure

Posted: Sat Dec 05, 2020 9:46 am
by Fred
Hi Texomans.

I'm sorry you're experiencing that issue, but I could not reproduce it myself. I just tried sending a report using the same settings (FTPS, not passive) and it worked fine. See the screenshot below. You could check out your server logs to see if there is any FTP related error. If your server tells you something bout it please post back. I'd like to know what's happening as much as you, so I could fix it.
ftp.png (54.4 KiB) Viewed 2994 times

Re: FTP Failure

Posted: Sun Dec 06, 2020 12:04 am
by texomans
I got it working. I was using a custom port on the external side of the firewall forwarding to port 21 on the server. Seems that this was the issue. I changed the firewall to accept port 21 and forward as usual, and this seems to have solved the issue. I was using the "Server Name:", but this still did not work. It is working now, although not the best security by using the default port, but it works. I will leave it like this for the time being. (Not usre if it may be helpful for someone else, but I am using a QNAP TS-251+ as our FTP server as well as other functions such as WebDav, http and PHP site hosting. Not usre how, but maybe the QNAP was/is the cause.)

Thank you for the functionality confirmation.

Re: FTP Failure

Posted: Sun Dec 06, 2020 9:13 am
by Fred
Thanks for posting back your solution. Although it still does not explain why WinSCP managed to send files and UVK didn't.

Anyway, glad you could work it out.